Browse Source

upgrade ansible 2.9

Fixes: main/infrastructure#299
keep-around/33e2d19fe5d11943ffc03a22d1d90141d6c8211c
Loïc Dachary 1 year ago
parent
commit
337fc99e50
Signed by: dachary GPG Key ID: 992D23B392F9E4F2
  1. 2
      Pipfile
  2. 34
      Pipfile.lock
  3. 4
      requirements-dev.txt
  4. 6
      requirements.txt

2
Pipfile

@ -19,7 +19,7 @@ dnspython = "==1.16.0"
pipenv-to-requirements = "*"
[packages]
ansible = "==2.7.17"
ansible = "~=2.9.0"
beautifulsoup4 = "==4.7.1"
cliff = "*"
django = "==2.2"

34
Pipfile.lock

@ -1,7 +1,7 @@
{
"_meta": {
"hash": {
"sha256": "00f633b8f4c0d4bd3727f9bfa77db8c8924cb684af4c5896f21834430caaec80"
"sha256": "e0b0ccf86a47afcb6bfb795f9ff3ebcb19c4b6c4f2859c0fec74891c0d7bfd41"
},
"pipfile-spec": 6,
"requires": {
@ -18,10 +18,10 @@
"default": {
"ansible": {
"hashes": [
"sha256:9fdb79c43f7ad972dc7ccff8a4e9553d623e52dc80b802c619568d3c38f94ccc"
"sha256:736a19fa6d608b4df2d6b48d31fec057b3f95abf62b7fda69ffa4a743e2f55b6"
],
"index": "pypi",
"version": "==2.7.17"
"version": "==2.9.15"
},
"appdirs": {
"hashes": [
@ -484,11 +484,11 @@
},
"openstacksdk": {
"hashes": [
"sha256:baa56d314567be979d86f1932359962f9fc9d72668d7f065c987ea167e49ac69",
"sha256:f8227e603b2489c2fe91e042c488a319281cfa2c17cc5e06fb149eeb52d44bb8"
"sha256:c9a2dd8c9d2cf44d7ba2075c7963f8fc79adf98f44af6aac2f4b612c12b798b3",
"sha256:cd8a23539961e2958a4e2e2240ec3d1d801a85d1bd23d7d8f22bbd554db42d2e"
],
"index": "pypi",
"version": "==0.51.0"
"version": "==0.52.0"
},
"os-client-config": {
"hashes": [
@ -514,11 +514,11 @@
},
"oslo.config": {
"hashes": [
"sha256:490bc3dc05ad69f77215dc650b1aa0a1bd5e5fb0415e925b6045552b828213aa",
"sha256:c214ab7b30946b7341248edc7ea000944163b460d395af99fd182598b82d5833"
"sha256:829a6dac59be1880e7b3ae510a7e122a43ba4bfb1d90f59ccefc90d8549d82ad",
"sha256:a3b9f9e6e74e40baa46bdb1a94b149087388003f2a51e591cf937e864c951ee0"
],
"markers": "python_version >= '3.6'",
"version": "==8.3.2"
"version": "==8.3.3"
},
"oslo.i18n": {
"hashes": [
@ -733,11 +733,13 @@
"sha256:06a0d7ba600ce0b2d2fe2e78453a470b5a6e000a985dd4a4e54e436cc36b0e97",
"sha256:240097ff019d7c70a4922b6869d8a86407758333f02203e0fc6ff79c5dcede76",
"sha256:4f4b913ca1a7319b33cfb1369e91e50354d6f07a135f3b901aca02aa95940bd2",
"sha256:6034f55dab5fea9e53f436aa68fa3ace2634918e8b5994d82f3621c04ff5ed2e",
"sha256:69f00dca373f240f842b2931fb2c7e14ddbacd1397d57157a9b005a6a9942648",
"sha256:73f099454b799e05e5ab51423c7bcf361c58d3206fa7b0d555426b1f4d9a3eaf",
"sha256:74809a57b329d6cc0fdccee6318f44b9b8649961fa73144a98735b0aaf029f1f",
"sha256:7739fc0fa8205b3ee8808aea45e968bc90082c10aef6ea95e855e10abf4a37b2",
"sha256:95f71d2af0ff4227885f7a6605c37fd53d3a106fcab511b8860ecca9fcf400ee",
"sha256:ad9c67312c84def58f3c04504727ca879cb0013b2517c85a9a253f0cb6380c0a",
"sha256:b8eac752c5e14d3eca0e6dd9199cd627518cb5ec06add0de9d32baeee6fe645d",
"sha256:cc8955cfbfc7a115fa81d85284ee61147059a753344bc51098f3ccd69b0d7e0c",
"sha256:d13155f591e6fcc1ec3b30685d50bf0711574e2c0dfffd7644babf8b5102ca1a"
@ -1362,11 +1364,11 @@
},
"tqdm": {
"hashes": [
"sha256:18d6a615aedd09ec8456d9524489dab330af4bd5c2a14a76eb3f9a0e14471afe",
"sha256:80d9d5165d678dbd027dd102dfb99f71bf05f333b61fb761dbba13b4ab719ead"
"sha256:3d3f1470d26642e88bd3f73353cb6ff4c51ef7d5d7efef763238f4bc1f7e4e81",
"sha256:5ff3f5232b19fa4c5531641e480b7fad4598819f708a32eb815e6ea41c5fa313"
],
"markers": "python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"version": "==4.52.0"
"markers": "python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"version": "==4.53.0"
},
"twine": {
"hashes": [
@ -1386,11 +1388,11 @@
},
"virtualenv": {
"hashes": [
"sha256:b0011228208944ce71052987437d3843e05690b2f23d1c7da4263fde104c97a2",
"sha256:b8d6110f493af256a40d65e29846c69340a947669eec8ce784fcf3dd3af28380"
"sha256:6af42359fbb33a6c7eab4d3246524b96fd9d8e07e7141b7a65998f96e28b2c57",
"sha256:fd4147c5ba3f694e2e4fc3c767407dc2226899623bb9b49c2f15637c2ee335b3"
],
"markers": "python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'",
"version": "==20.1.0"
"version": "==20.2.0"
},
"virtualenv-clone": {
"hashes": [

4
requirements-dev.txt

@ -59,9 +59,9 @@ sphinxcontrib-serializinghtml==1.1.4 ; python_version >= '3.5'
sphinxcontrib-websupport==1.2.4 ; python_version >= '3.5'
toml==0.10.2 ; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'
tox==3.15.0
tqdm==4.52.0 ; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'
tqdm==4.53.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
twine==1.13.0
urllib3==1.26.2 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3, 3.4' and python_version < '4'
virtualenv-clone==0.5.4 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
virtualenv==20.1.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
virtualenv==20.2.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
webencodings==0.5.1

6
requirements.txt

@ -10,7 +10,7 @@
# `Pipfile.lock` and then regenerate `requirements*.txt`.
################################################################################
ansible==2.7.17
ansible==2.9.15
appdirs==1.4.4
atomicwrites==1.4.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
attrs==20.3.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
@ -55,11 +55,11 @@ munch==2.5.0
netaddr==0.7.19
netifaces==0.10.9
oauthlib==3.1.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
openstacksdk==0.51.0
openstacksdk==0.52.0
os-client-config==2.1.0
os-service-types==1.7.0
osc-lib==2.3.0 ; python_version >= '3.6'
oslo.config==8.3.2 ; python_version >= '3.6'
oslo.config==8.3.3 ; python_version >= '3.6'
oslo.i18n==5.0.1 ; python_version >= '3.6'
oslo.serialization==4.0.1 ; python_version >= '3.6'
oslo.utils==4.7.0 ; python_version >= '3.6'

Loading…
Cancel
Save