DroidFS crash (CryFS) #12

Closed
opened 2023-05-06 17:39:03 +02:00 by Roal · 12 comments

Can't use CryFS the app crash :
1- Create a CryFS volume
2- Take a picture with DroidFS
3- You are logged out automatically
4- Open the app and type your password, the app crash trying to open the volume

V2.0.1

type: crash
osVersion: google/bluejay/bluejay:13/TQ2A.230505.002/2023050100:user/release-keys
package: sushi.hardcore.droidfs:31
process: sushi.hardcore.droidfs
processUptime: 77 + 263 ms

java.lang.RuntimeException: Unable to start activity ComponentInfo{sushi.hardcore.droidfs/sushi.hardcore.droidfs.explorers.ExplorerActivity}: java.lang.NullPointerException
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3642)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3779)
	at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:101)
	at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:138)
	at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2304)
	at android.os.Handler.dispatchMessage(Handler.java:106)
	at android.os.Looper.loopOnce(Looper.java:201)
	at android.os.Looper.loop(Looper.java:288)
	at android.app.ActivityThread.main(ActivityThread.java:7891)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548)
	at com.android.internal.os.ExecInit.main(ExecInit.java:49)
	at com.android.internal.os.RuntimeInit.nativeFinishInit(Native Method)
	at com.android.internal.os.RuntimeInit.main(RuntimeInit.java:355)
Caused by: java.lang.NullPointerException
	at sushi.hardcore.droidfs.explorers.BaseExplorerActivity.onCreate(BaseExplorerActivity.kt:80)
	at android.app.Activity.performCreate(Activity.java:8388)
	at android.app.Activity.performCreate(Activity.java:8367)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1422)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3623)
	... 14 more

Can't use CryFS the app crash : 1- Create a CryFS volume 2- Take a picture with DroidFS 3- You are logged out automatically 4- Open the app and type your password, the app crash trying to open the volume V2.0.1 ``` type: crash osVersion: google/bluejay/bluejay:13/TQ2A.230505.002/2023050100:user/release-keys package: sushi.hardcore.droidfs:31 process: sushi.hardcore.droidfs processUptime: 77 + 263 ms java.lang.RuntimeException: Unable to start activity ComponentInfo{sushi.hardcore.droidfs/sushi.hardcore.droidfs.explorers.ExplorerActivity}: java.lang.NullPointerException at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3642) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3779) at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:101) at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:138) at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2304) at android.os.Handler.dispatchMessage(Handler.java:106) at android.os.Looper.loopOnce(Looper.java:201) at android.os.Looper.loop(Looper.java:288) at android.app.ActivityThread.main(ActivityThread.java:7891) at java.lang.reflect.Method.invoke(Native Method) at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548) at com.android.internal.os.ExecInit.main(ExecInit.java:49) at com.android.internal.os.RuntimeInit.nativeFinishInit(Native Method) at com.android.internal.os.RuntimeInit.main(RuntimeInit.java:355) Caused by: java.lang.NullPointerException at sushi.hardcore.droidfs.explorers.BaseExplorerActivity.onCreate(BaseExplorerActivity.kt:80) at android.app.Activity.performCreate(Activity.java:8388) at android.app.Activity.performCreate(Activity.java:8367) at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1422) at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3623) ... 14 more ```

I cannot reproduce this. Pictures are saved correctly for me. Can you please attach a logcat of when you take the picture?

Does it also happen with gocryptfs? Are the pictures saved or no file is created? Are you able to import files into the volume? Did you created the CryFS volume with DroidFS or with the original cryfs program?

I cannot reproduce this. Pictures are saved correctly for me. Can you please attach a logcat of when you take the picture? Does it also happen with gocryptfs? Are the pictures saved or no file is created? Are you able to import files into the volume? Did you created the CryFS volume with DroidFS or with the original cryfs program?

In fact I can't add anything in CryFS volume. With gocryptfs anything it's OK.
Files are created in the Android folder, but DroidFS can't open the volume afterwards.

Did you created the CryFS volume with DroidFS

Yes

In fact I can't add anything in CryFS volume. With gocryptfs anything it's OK. Files are created in the Android folder, but DroidFS can't open the volume afterwards. > Did you created the CryFS volume with DroidFS Yes

OK, can you reproduce the bug even after app re-installation? Does it work with hidden CryFS volumes? Are you using the F-Droid APK or the one provided in the releases page?

A complete logcat of the crash would be really helpful.

OK, can you reproduce the bug even after app re-installation? Does it work with hidden CryFS volumes? Are you using the F-Droid APK or the one provided in the releases page? A complete logcat of the crash would be really helpful.

Are you using the F-Droid APK or the one provided in the releases page?

You pointed me to the right direction. I download the app with Obtainium app from Github. Don't know which version. Now with the universal release it's ok.
Thank you.

> Are you using the F-Droid APK or the one provided in the releases page? You pointed me to the right direction. I download the app with Obtainium app from Github. Don't know which version. Now with the universal release it's ok. Thank you.

Is it possible to open a CryFS volume from a fresh installation ?

Is it possible to open a CryFS volume from a fresh installation ?

Good to know, but that's strange. The F-Droid version works fine for me.

I'm not sure to understand what you mean but yes, DroidFS should be able to open CryFS volumes after a fresh install.

Good to know, but that's strange. The F-Droid version works fine for me. I'm not sure to understand what you mean but yes, DroidFS should be able to open CryFS volumes after a fresh install.

I mean, I use the app but for some reason I need to factory reset the phone. I restore the files and the app.
I tried it with clear cache and clear storage options. And DroidFS don't ask me to restore it. But it's an other thing.

I mean, I use the app but for some reason I need to factory reset the phone. I restore the files and the app. I tried it with clear cache and clear storage options. And DroidFS don't ask me to restore it. But it's an other thing.
Roal closed this issue 2023-05-06 23:45:00 +02:00

DroidFS doesn't have any backup/restore feature so I think this is expected. Volumes should be backed up independently.

DroidFS doesn't have any backup/restore feature so I think this is expected. Volumes should be backed up independently.

+1 for this feature Modifiable CryFS scrypt parameters to have ability to change the size blocks.

+1 for this feature [Modifiable CryFS scrypt parameters](https://forge.chapril.org/hardcoresushi/DroidFS/src/branch/master/TODO.md) to have ability to change the size blocks.

This feature consists in allowing the user to choose the parameters of the scrypt KDF. It has nothing to do with the blocks size of the volume (--blocksize option in CryFS). Would you want that feature to be added?

This feature consists in allowing the user to choose the parameters of the scrypt KDF. It has nothing to do with the blocks size of the volume (`--blocksize` option in CryFS). Would you want that feature to be added?

Would you want that feature to be added?

Yes please. 16 ko default block seems smaller than a simple text file. I suppose this feature will split only files larger than the blocksize.

> Would you want that feature to be added? Yes please. 16 ko default block seems smaller than a simple text file. I suppose this feature will split only files larger than the blocksize.

OK then open an issue for this feature request please.

OK then open an issue for this feature request please.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: hardcoresushi/DroidFS#12
There is no content yet.