Investigate how to filter out moving background #2

Closed
opened 7 months ago by Yun · 1 comments
Yun commented 7 months ago

There may still be noise caused by bright pixels moving in the background.

One idea is to use opencv to calculate dense optical flow for each frame and use the portions with close to no movement as an additional mask that gets applied to the image.
Another idea would be to use background subtraction against the previous frame.
calculation of these masks will probably need to be done before the main multiprocessing part.

There may still be noise caused by bright pixels moving in the background. One idea is to use opencv to calculate dense [optical flow](https://docs.opencv.org/master/d4/dee/tutorial_optical_flow.html) for each frame and use the portions with close to no movement as an additional mask that gets applied to the image. Another idea would be to use [background subtraction](https://docs.opencv.org/3.4/d1/dc5/tutorial_background_subtraction.html) against the previous frame. calculation of these masks will probably need to be done before the main multiprocessing part.
Poster

Doesn't seem like this is that big of an issue with PaddleOCR

Doesn't seem like this is that big of an issue with PaddleOCR
Yun closed this issue 6 months ago
Sign in to join this conversation.
No Label
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.