[nvim] update lua_lsp config

dev
David JULIEN 11 months ago
parent a532830d77
commit a137ededaa
  1. 11
      .config/nvim/lua/lsp/lua.lua

@ -11,6 +11,10 @@ local sumneko_root_path = vim.fn.stdpath("data") ..
local sumneko_binary = sumneko_root_path .. "/bin/" .. system_name ..
"/lua-language-server"
local runtime_path = vim.split(package.path, ';')
table.insert(runtime_path, "lua/?.lua")
table.insert(runtime_path, "lua/?/init.lua")
require'lspconfig'.sumneko_lua.setup {
cmd = {sumneko_binary, "-E", sumneko_root_path .. "/main.lua"};
settings = {
@ -19,7 +23,7 @@ require'lspconfig'.sumneko_lua.setup {
-- Tell the language server which version of Lua you're using (most likely LuaJIT in the case of Neovim)
version = 'LuaJIT',
-- Setup your lua path
path = vim.split(package.path, ';'),
path = runtime_path,
},
diagnostics = {
-- Get the language server to recognize the `vim` global
@ -27,10 +31,7 @@ require'lspconfig'.sumneko_lua.setup {
},
workspace = {
-- Make the server aware of Neovim runtime files
library = {
[vim.fn.expand('$VIMRUNTIME/lua')] = true,
[vim.fn.expand('$VIMRUNTIME/lua/vim/lsp')] = true,
},
library = vim.api.nvim_get_runtime_file("", true),
},
-- Do not send telemetry data containing a randomized but unique identifier
telemetry = {

Loading…
Cancel
Save